
ELEC3105 Winter 2021 – Lab 0       Instructor: Kupchak 
 
 

ELEC 3105 Lab 0 

Page 1 of 13 

 

 

 
 
 

 
 
 
 

 

LAB 0:  Orientation to Remote Login and Multisim Live 
 
 

Disclaimer: Any saved documents are not permanent on VLSI lab computers 
unless saved on the H: drive. 

Documents saved on drives other than H: will be erased. 
 

It is also suggested you save a backup on a networked platform 
 such as OneDrive or Google Drive 

 
 

Purpose: 
 

This semester of ELEC 3105 is being delivered completely online, which includes the laboratory component.  
As you progress through the course you will be required to complete versions of the ELEC 3105 labs that have 
been modified in a way that they can be completed at your place of residence as long as you have a reliable 
internet connection.  This document is an introductory laboratory designed to get everyone familiar with the tools 
you will need throughout the term to complete the assigned lab component.    
 
This lab is worth 1% of your final grade and it is important to complete the exercises in this document to ensure 
you have the base skill set needed to complete the core labs in an efficient and effective manner.  For more 
information about the expectations of each student regarding the labs please refer to the course syllabus 
posted on cuLearn.  

 

 

Resources Needed – these will be needed throughout the term 

 

(i) Device with Windows/Mac/etc. operating system (desktop or laptop is highly recommended) 
(ii) Reliable internet connection 
(iii) Carleton email address and password 
 
 

 

Part 1:  Connecting to Carleton’s VPN (Virtual Private Network) 
 
A large portion of the laboratory component for this course will require you to have remote access to equipment 
and devices on campus.  To ensure the security of the university networks, all students registered in this course 
will be required to use Carleton’s VPN service for remote login purposes.  To set this up go to this URL: 
 
https://carleton.ca/its/help-centre/remote-access/ 

 
Click on the instructions corresponding to your chosen operating system as shown in Figure 1. 

 

https://carleton.ca/its/help-centre/remote-access/
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Figure 1:  Carleton Remote Access (VPN) Website 

 
You will be taken to a page providing instructions for you to set up your VPN based on your operating system.  
Once set up, you must connect to Carleton’s VPN (cuvpn.carleton.ca) before accessing the lab computers 
and required equipment (when necessary). 
 

Figure 2: Carleton VPN Connection Setup 

 
You will be prompted for your MyCarletonOne (Carleton Central) username and password to log into the 
VPN.  Note that this is different than the login information used to access the lab server and computers.  An 
example of logging into the VPN using Windows 10 can be seen below in Figure 3. 
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Figure 3: Cisco AnyConnect on Windows Computer Accessing Carleton VPN 

 
If you have any issues setting up a VPN connection, please contact Information Technology Services (ITS) for 
assistance.  Their contact information can be found in the link below. 
 
https://carleton.ca/its/contact/ 
 

 

  

https://carleton.ca/its/contact/
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Part 2:  Remote Login into VLSI Lab Computers 

 

Once you are connected to Carleton’s VPN you can access the lab server and computers. Logging into these 
computers also gives access to your H: drive, where you should be saving your files. When working on lab 
computers, do not save files to locations other than your H: drive. This includes the Desktop, Documents, 
Downloads, and C: drive. These files not only slow down the computer but will also be periodically deleted. 

 

First, you must login to the VLSI server using a remote desktop connection. Then, from the server you will use 
another, nested, remote desktop connection to connect to the VLSI lab computers. From the lab computer 
desktop, you will be able to access ANSYS and/or control the lab equipment (if necessary). Figure 4 below 
shows this process. 

 

 
Figure 4:  Remote Desktop Hierarchy Diagram 

 

To login to the VLSI server, open the Remote Desktop Connection app if you are using a Windows computer, 
or the appropriate equivalent on another operating system.  The shortcut icon for this app can be seen in Figure 
5. 

 

 
Figure 5: Windows Remote Desktop Connection Shortcut Icon 

 

 

 

 

 

 

 

Local 
Computer 
Desktop

• From Local Computer, Connect to 
Carleton VPN. Then Remote Desktop 
Into Server

VLSI Server 
Desktop

• From Server, Access Various 
Applications



ELEC3105 Winter 2021 – Lab 0       Instructor: Kupchak 
 
 

ELEC 3105 Lab 0 

Page 5 of 13 

 

 

 
 
 

 
 
 
 

 

 

Once open you will be greeted by a window like the one in Figure 6. 

 

 
Figure 6: Windows Remote Desktop Connection Window 

 

At the bottom right, click Show Options to expand the Computer and Username tabs. 

 

For Computer enter 134.117.38.204 (Eli), and for Username enter VLSI\{cuLearn Username}. For 
example, if your cuLearn username is ‘johndoe’, the Username would be ‘VLSI\johndoe’.  This can be seen 
in Figure 7 below. 

 

 
Figure 7:  Expanded Remote Desktop Connection Window 
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Click Connect.  You will be prompted for a password. This password is pW{Student Number}.  So, if your 
student number is 123456789, then your password is ‘pW123456789’. 

 

This will bring you to the VLSI server.  From here you can access the licensed software for completing your 
work during your labs. You can also organize your remote desktop into compartments using the Fences 
application.  This can be seen in Figure 8.   

 

  
Figure 8:  Remote Desktop App Connecting to PC## From Server Virtual Desktop 

 

Note that the remote desktop connection acts as a window, and can therefore be minimized, resized, and 
closed.  This can be seen in Figure 9.  If closed, your remote access session will disconnect, but it will leave 
you logged into the computer/server without closing the programs you were using.  This can lead to major 
issues for any users after you, including not being able to control the equipment, or losing saved files. Always 
log off the Remote Computer after you are done your work. 

 

When you are done with the remote desktop session, make sure you log off the lab computer.  This will 
also end your remote access session.  Do this by selecting the Windows button in the bottom left-hand corner 
and selecting logout.  This can be seen in Figure 7.  Trying to use CTRL + ALT + DELETE will bring up the 
options for your local computer, not the remote session. 
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Part 3:  Getting the ANSYS Example Working 

 

Ansys Maxwell will be used for Lab 1 and Lab 2 for performing electromagnetic simulations. To perform these 
simulations, you will need to be connected to the Eli server as shown in Part 2. You can fine Ansys Electronics 
Desktop on the server desktop as seen in Figure 9. 

 

 
Figure 9: ANSYS Shortcut 

 

Upon first starting up ANSYS, you will be prompted to change to a new ANSYS product library set, so click 
OK. In the Directory Options window which will follow, change the Project Directory address to 
H:\ELEC3105, if no such directory exists, make a folder on your H Drive for this. Override the default 
Temporary Directory and enter H:\ELEC3105\temp\Ansys, see Figure 10. 

 

 
Figure 10: Directory Options for First Startup 

 

Click OK, then Yes, No I am not willing to participate, OK, and Close. Once the application has open, you 
must choose Project → Insert Maxwell 2D Design. 

 

With the new subproject open, you will see the X, Y, and Z normal vectors, and the scale legend. Open the 
example file by going to File → Open Examples… → Maxwell 2D → Getting_Started and open the 
Solenoid file. Below is the same Solenoid in 3D 
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Figure 11: Open View 3D Equivalent of the 2D Solenoid Model 

 

Since this is already constructed with a current flowing through the core (red), you can skip to analysing the 
schematic and displaying the magnetic field strength. 

 

In the Project Manager window, the Solenoid project is displayed. You must expand the list and find Analysis, 
which can be expand to reveal Setup1. In Analysis, Setup1 is ready for analyses, right click it and Analyze. 
You may be prompted to save your project at this point if you have not done so. Navigate to the folder you 
created H:\ELEC3105 and create a new folder for your project lab 0. 

 

Highlight the whole bound space (click anywhere on the cartesian plane then Ctrl-a), right click Field 
Overlays from the project panel and choose Fields → H → Mag_H → Done. 

 

At this point, the magnetic field strength should become visible. If it is not, expand Field Overlays and select 
the Mag_H in H. Other fields can also be selected for using the same method. 

 

If you get lost at any point, or would like to perform this example from scratch, please follow the instructions 
seen here: 

https://www.physicsforums.com/attachments/tutorial-2d-magnetostatic-solenoid-pdf.78651/ 

 

 

Part 4:  Running ANSYS Maxwell 2D 

 

For Lab 1 you will need to make your geometries from scratch. Now that you have had experience loading a 
premade example in ANSYS, we will move through a few exercises that will help you gain familiarity with 
creating ANSYS geometries.  ANSYS can be a bit frustrating a first, so it is important to get familiar with the 
order of operations such that Lab 1 can be completed efficiently. 

 
Note: It is always a good idea to regularly save your projects (H:\ Drive) to prevent losing progress. If 
the instructions below are not clear for you, ask your TA or research online. Assume a plate thickness 
of 1mm unless otherwise stated. 

1. Start the ANSYS Electronics Desktop program and select Project, then Insert Maxwell 2D Design. 

https://www.physicsforums.com/attachments/tutorial-2d-magnetostatic-solenoid-pdf.78651/
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Now, select the Maxwell 2D menu option and click on Solution type. 

 
In the window the opens up, select the required solution type, for lab #1 it is Electrostatic, for lab #2 it 
is Magnetostatic. Click OK once you selected the correct option for you. 

 
2. Click on the Draw line button shown below in order to draw the required structure geometry, depending on 

the problem you are currently trying to simulate. 

 
Click somewhere on the white grid located across the center of the interface in order to place a point, click 
again to place another point and a line will be automatically drawn between them. Play around with this 
function until you are comfortable using it to draw different shapes. 
 
It is also possible to use the rectangle and circle functions in order to draw shapes. Familiarize yourself 
with how these functions work as well. You can zoom in and out by holding the control key and scrolling 
with your mouse, this may help in the case where you need a finer grid size. (Zoom in for a finer grid 
spacing). 
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If a ring geometry is required, draw one circle with a radius equal to the radius of the ring’s outside edge. 
Then draw another circle inside the first circle with a radius equal to the ring’s inner edge as shown below. 

 
Next select both circles. You may do this by holding the control key, selecting the larger circle, then select 
the smaller inner circle, and releasing the control key. Once this is done, right click on the smaller inner 
circle, then navigate and click on the menu option shown below. 

 
Click the OK button on the window the opens. You should be left with a ring as shown below (this may 
take a couple tries to get the swing of). 

 
3. Once the required shapes are drawn according to the problem, click on a shape in order to select it. Once 

it is selected it will change color and its properties will be displayed in the properties pane on the left side 

of the interface. Select the property box containing the material value and click on Edit and a window will 

open. In the “Search by name” box, type in the name of the material you would like to simulate, select it 

from the list below the box, and click OK. 
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Do this for each different shape using the required material. 
 

4. Once the geometries are drawn and have had materials assigned to them, draw a large rectangle around 

them and set the material of this rectangle to air. You may also change the transparency of this rectangle 

by changing the “Transparent” value located in the Properties pane.  

 
Once this rectangle is drawn, press the E key1, and then while holding the control key, select all four 
edges of the large rectangle you just drew that encapsulates the rest of the shapes. Now right click 
anywhere on the white grid and from the right click menu, navigate to Assign Boundary (Balloon), and 
click on Charge (if you get a boundary error try carefully repeating this process). Set the Balloon type as 
Charge in the window that opens up, and click OK. You may now press the O key to return to object 
selection mode (as opposed to edge selection mode). 
  
It is also possible to hide or show the different geometries that you have drawn by clicking on the eye 
icon in the upper toolbar and selecting which shapes you want to remain visible in the window that opens. 
This is shown in the figure below. Note that if a shape is not visible, it will still be included within the 
simulation. 

 
 

5. In order to assign voltages to materials, right click on the material that you wish to assign an excitation 

(for example a voltage), navigate to Assign Excitation in the right click menu, and click on Voltage. Set 

the voltage value required and click ok. 

 
6. Verify that the shapes drawn have the correct size ratios. You should now change the scale by navigating 

to the top Modeler menu and clicking on it, then select Units and click it. On the window that appears 

                                                 
1 The E key enables edge selection mode. Other common options are Objects (O) and Faces (F). Objects is the 

default selection mode. 
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check the Rescale to new units box and select cm or the proper unit for your drawing. Play around with 

this until your units are correct, you may verify if they are correct by using the scale located at the bottom 

of the white grid workspace interface shown below in the example for problem 1. (The copper plate 

thickness is set to 1mm along y in this figure.) 

            

 

7. In order to simulate this project you must first add a solution setup by navigating to the following menu 

shown below and clicking on Add Solution Setup. 
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Click OK on the window that opens and then save your project by pressing down on the control key and 
S key at the same time. Choose a suitable location to save your project if required. 
 

8. In order to simulate the project, navigate to the Project menu and click on Analyze All, as shown below. 

You must repeat this if you make any changes. 

 
 

9. To plot the results, select the large air rectangle and right click on “Field Overlays” within the Project 

Manager pane on the left side of the interface as shown below. Select the type of result you would like to 

plot and a window will open. Click Done on the window and your plot will be visible. 
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10. To find the capacitance, before analyzing the problem navigate to the project manager pane on the left 

side. Right click on Parameters and assign a matrix. Select one signal line and one signal ground (one 

for each source). Click OK then run the simulation. Once the simulation is completed, expand the 

Parameters tree, right click on Matrix1 or the matrix you created, and choose View Solution. The 

capacitance units are shown near the top-right of the window and the value is shown in the large display 

box in the bottom half of the window.  

 
11. Explore the Project Manager pane as it contains lots of useful information. You can modify field 

overlays by right clicking on Field Overlays and clicking on Modify Plot Attributes. This is useful for 

changing the resolution, color, and scale of the legend. You may also see your excitations and 

boundaries along with other parameters. Explore the Properties pane for useful settings too. You can 

rename shapes that you’ve created to custom names for easier identification if needed. 

 
This brief tutorial on using the ANSYS Maxwell Solver should be enough to get you started, there is 
plenty of documentation available on the internet as well as built into the program itself. 
 
Once you have completed 10., check in with your TA (Zoom or BBB) to let them know you are 
done. Your TA will mark you as present and this will be sufficient for the 1% credit for this lab. 

 

 


